Solved: Multidex issue with Flutter


Asked by SpoonerNZ on April 17, 2018 (source).

I'm getting the following error compiling with gradle using Flutter in Android Studio:

Dex: Error converting bytecode to dex:
Cause: Multiple dex files define Lcom/google/android/gms/internal/zzcew;
UNEXPECTED TOP-LEVEL EXCEPTION: Multiple dex files define Lcom/google/android/gms/internal/zzcew;

[... stacktrace omitted for brevity ...]

* What went wrong:
Execution failed for task ':app:transformDexArchiveWithDexMergerForDebug'.
> Multiple dex files define Lcom/google/android/gms/internal/zzcew;

The short version

This only occurs if I add enough dependencies, as might be expected. I've enabled multidex and added the multidex dependency in the Android project build.gradle file as per instructions (, but wasn't sure what to do about step 2 in "Configure your app for multidex" for a Flutter App, or even whether the omission of that step was the problem.

Steps to recreate:

  1. Select File/New/New Flutter Project from the toolbar
  2. Select "Flutter Application"
  3. Include Kotlin & Swift support
  4. Check the app compiles and runs
  5. Add the following to dependencies in pubspec.yaml:

      flutter_google_place_picker: "^0.0.1"
      location: "^1.2.0"
  6. Hit Packages Get in Android Studio or run flutter packages get in the project directory
  7. Modify android/app/build.gradle to add the following sections in the appropriate places:

    dependencies {
      compile ''
    android {
        defaultConfig {
            multiDexEnabled true
  8. Select Run/Run from the toolbar

Other things I've tried

  1. Replacing the "compile" dependency in build.gradle with each of the following:

    compile ''
    implementation ''
    implementation ''
  2. Following the multidex steps for each of my dependencies; i.e. modifying their build.gradle files, enabling multidex and adding the multidex dependency.

  3. Modifying minSdkVersion to each of 21 and 27 in each of the build.gradle files for my project and its dependencies, and enabling multidex for them.
  4. Enabling minifying for my project.
  5. Replacing location: "^1.2.0" with geolocation: "^0.2.1"
  6. Not enabling multidex at all (i.e. skipping step 7 of recreating). This results in the following error:

    FAILURE: Build failed with an exception.
    * What went wrong:
    Execution failed for task ':app:transformDexArchiveWithExternalLibsDexMergerForDebug'.
    > java.lang.RuntimeException: java.lang.RuntimeException: Unable to merge dex

Flutter doctor output

$ flutter doctor -v
[√] Flutter (Channel beta, v0.2.8, on Microsoft Windows [Version 10.0.16299.371], locale en-GB)
    • Flutter version 0.2.8 at D:\flutter
    • Framework revision b397406561 (2 weeks ago), 2018-04-02 13:53:20 -0700
    • Engine revision c903c217a1
    • Dart version 2.0.0-dev.43.0.flutter-52afcba357

[√] Android toolchain - develop for Android devices (Android SDK 27.0.3)
    • Android SDK at C:\Users\Dave\AppData\Local\Android\sdk
    • Android NDK location not configured (optional; useful for native profiling support)
    • Platform android-27, build-tools 27.0.3
    • Java binary at: D:\AndroidDev\jre\bin\java
    • Java version OpenJDK Runtime Environment (build 1.8.0_152-release-1024-b02)
    • All Android licenses accepted.

[√] Android Studio (version 3.1)
    • Android Studio at D:\AndroidDev
    • Java version OpenJDK Runtime Environment (build 1.8.0_152-release-1024-b02)

[√] Connected devices (1 available)
    • Android SDK built for x86 64 • emulator-5554 • android-x64 • Android 5.1.1 (API 22) (emulator)

• No issues found!


Question answered by Mikkel R (source).

Your two packages seem to disagree on their transitive dependencies. One wants 11.6.+, the other wants 11.+ of some play-services dependencies. Since both 11.6.2 and 11.8.0 are out there, this is going to end up with a conflict.

If you run ./gradlew androidDependencies in your android/ folder, you get a listing of the result of dependency resolution, containing, among others, the following:

+--- :flutter_google_place_picker (variant: release)
+---[email protected]
+---[email protected]
+---[email protected]
+---[email protected]
+---[email protected]
+---[email protected]

These 11.6.2 and 11.8.0 packages are not going to work together. To resolve this, you need to patch your dependencies to be consistent with each other, or add a dependency override to the top level of your android/app/build.gradle file and hope for the best:

configurations.all {
    resolutionStrategy {
        force ''
        force ''