[Solved] I am getting this errors "cmdline-tools component is missing" after installing flutter and android studio... i added andorid sdk. how to solve them?

Question

Asked by Stark on July 03, 2021 (source).

Android toolchain - develop for Android devices (Android SDK version 30.0.3) X cmdline-tools component is missing Run path/to/sdkmanager --install "cmdline-tools;latest" See https://developer.android.com/studio/command-line for more details.

Answer

Question answered by Prajeet N (source).

If you are a mac user, Just open your terminal and paste

cd Library/Android/sdk/tools/bin./sdkmanager --install "cmdline-tools;latest"

and hit Enter.

This command will install latest version of cmdline-tools.

Then, Run Flutter doctor, The error will be gone.

ANDROID ANDROID-STUDIO FLUTTER FLUTTER-DOCTOR
SHARE: