[Solved] Cannot run with sound null safety, because the following dependencies [build\windows\flutter\flutter_assemble.vcxproj]

Question

Asked by Dev94 on January 05, 2022 (source).

I have shifted my entire code to latest dart version 2.15.1. Now I am trying to run the code and it is giving this error.

Image1

Why I am getting this error. Anyone please help me.

Thanks

Answer

Question answered by Diwyansh (source).

This is because some of your dependencies that you are using in your project doesn't support null-safety or Your project itself doesn't support null-safety but using dependencies that supports null-safety. To get rid of this problem you can try upgrading the dependency that is causing the error and if there's no update available for that plugin that run your project using below command :

To Run

flutter run --no-sound-null-safety

To Build

flutter build apk --release --no-sound-null-safety

Video Answers on YouTube

DART FLUTTER
SHARE: